Power and Root calculation result are of a different type than number

Today I ran into something odd in Triggre that I can’t explain or solve, so maybe the community can help me out here.

When performing a calculation in two separate flows after a decision, the result can be named the same, providing the type of the result is the same. Which is quite handy of course.

It so happens I have a generic flow part to perform simple calculations in a user flow. The inputs are two Number values and an Operator, selected through a picklist. Based on a decision that has been placed on the Operator.

When the operator says “Add A to B” I do a calculation adding Value A to Value B and call the calculation “Result”. Same happens for substracting, dividing, etc.
But then I added “A to the power of B”. This calculation requires the use of the function with the same name. Again I tried to call the result “Result”, because my flow part has just one output parameter named Result.

This failed, because Tiggre says:
Which is odd, since the outcome should be as much a number as te outcome of the other calculations. But that is not where it ends.
I decided to give the result the name “Result2” and add it as an extra output parameter to the flow part. But…when I try to add the result to the output, there is no Result2 value to select. The result is not available at all as output.

I’ve tried multiplying the result with 1, but alas to no avail. Who can help?

Hi Sylvester,
This sounds very odd. Can you send me the design by email so I can investigate this situation?

Hi Eddie,
I’ve sent you an email with the reference to the relevant environment and flow part.

1 Like